Corrupted Session Replay data

Incident Report for Splunk Observability Cloud US0

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 13:50 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2025 - 13:38 PDT

Identified

An issue in the session replay processing pipeline is causing session replay data to be corrupted. Session replay data ingest is not impacted. We have identified the issue and are working on fixing it.
Posted Jul 11, 2025 - 12:15 PDT
This incident affected: Splunk RUM (Session Replay API, Session Replay Processor).