Splunk Observability APIs Errors and Active Alerts Page is Loading Slowly

Incident Report for Splunk Observability Cloud US0

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 12:44 PDT

Monitoring

A fix has been implemented and we are monitoring the results as backlog recovers. Alert states and event time series in the UI may be delayed while the backlog recovers.
Posted Jul 14, 2026 - 12:07 PDT

Update

We are continuing to work on a fix for this issue. A full recovery could take several hours
Posted Jul 14, 2026 - 10:52 PDT

Identified

Customer impact began around 7:00 AM PDT. We have identified a fix, but a full recovery could take several hours
Posted Jul 14, 2026 - 09:49 PDT

Investigating

We are currently investigating the issue. Certain APIs may be failing and active alert pages is loading slowly. No data is being dropped or lost.
Posted Jul 14, 2026 - 08:45 PDT
This incident affected: Splunk Observability Cloud API and Alerting.